package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(([{\[("']\w+[}\])"'])|(\w+))`)
var str = `word1{word2}[word3](word4)"word5"'word6'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}