$re = '/(?:top|order|orderBy)(\d*)?(Asc|Desc)?(?:By)?([a-zA-z]+)/m';
$str = 'top20AscByBlocks';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);