re = /(?:top|order|orderBy)(\d*)?(Asc|Desc)?(?:By)?([a-zA-z]+)/m
str = 'top20AscByBlocks'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end