import Foundation
let pattern = #"[\u0000-\u007F]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"?CNTN_CD=A0002400127&PAGE_CD=ET00_1&BLCK_NO=1&CMPT_CD=T0016&TEXT=한글패러미터"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)