use strict;
my $str = 'before a comma word,
end of sentence word.
end of line word
word at line start
prefix-word pattern
and word-postfix pattern
but not {word} as a tag
neither {word} nor
{word} here
word
{word}
{word should match
this should match too word}';
my $regex = qr/(?<!\{)word(?!\})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}