re = /(?<!\{)word(?!\})/m
str = 'before a comma word,
end of sentence word.
end of line word
word at line start
prefix-word pattern
and word-postfix pattern
but not {word} as a tag
neither {word} nor
{word} here
word
{word}
{word should match
this should match too word}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end