using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\bPP\b)(?:(?!\bFF\b).)*(?=\bFF\b)";
string input = @"abc FF def PP ghi,PP jkl,FF mno PP pqr FF,stu FF vwx,PP yza";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}