$re = '/(?<=\bPP\b)(?:(?!\bFF\b).)*(?=\bFF\b)/mxi';
$str = 'abc FF def PP ghi,PP jkl,FF mno PP pqr FF,stu FF vwx,PP yza';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);