$re = '/(?<=[0-9]),(?=[0-9])/';
$str = '|\'2,3\'|,|\'5,6\'|,|\'2,1\'|,|\'3\'|,|\'6,5\'|,|\'9\'|,|\'7\'|,|\'24,4\'|,|\'4\'|,|\'1,1\'|';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);