re = /(?<=[0-9]),(?=[0-9])/
str = '|\'2,3\'|,|\'5,6\'|,|\'2,1\'|,|\'3\'|,|\'6,5\'|,|\'9\'|,|\'7\'|,|\'24,4\'|,|\'4\'|,|\'1,1\'|'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end