$re = '/(?<=\s|^)#(\w*[A-Za-z_]+\w*)/m';
$str = '#ciao
https://docs.flarum.org/#goals
#ciao
#ciao
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);