re = /(?<=\s|^)#(\w*[A-Za-z_]+\w*)/m
str = '#ciao
https://docs.flarum.org/#goals
#ciao
#ciao
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end