re = /(\d*#\D)|(\d*#^)/m
str = '"8617722824323#312|86259920#None17722825198#"
1777213134#|+8617722824323#
8617722824323#312
1777213134#
8617722824323#312'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end