package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[JIRA\-\d+\][\sa-zA-Z]+$`)
var str = `[JIRA-1234] My PR description name`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}