$re = '/^\[JIRA\-\d+\][\sa-zA-Z]+$/m';
$str = '[JIRA-1234] My PR description name';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);