package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Send\s+(?<message>.*)\s+to\s+(?<name>.*)`)
var str = `Send Hi there to Jesus
Send Not to me to Peter`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}