$re = '/Send\s+(?<message>.*)\s+to\s+(?<name>.*)/';
$str = 'Send Hi there to Jesus
Send Not to me to Peter';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);