#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[A-Za-z\d]{3})[A-Za-z]*(?:\d[A-Za-z]*){0,2}$"
Local $sString = "aaa" & @CRLF & _
"1aa" & @CRLF & _
"11a" & @CRLF & _
"111" & @CRLF & _
"a1a" & @CRLF & _
"aa1" & @CRLF & _
"a11" & @CRLF & _
"1a1" & @CRLF & _
"" & @CRLF & _
"test12" & @CRLF & _
"123test" & @CRLF & _
"" & @CRLF & _
"%test#$3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")