$re = '/^(?=[A-Za-z\d]{3})[A-Za-z]*(?:\d[A-Za-z]*){0,2}$/m';
$str = 'aaa
1aa
11a
111
a1a
aa1
a11
1a1
test12
123test
%test#$3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);