import re
regex = re.compile(r"\bCisco\s+(.*?)\s+Software\b", flags=re.MULTILINE)
test_str = ("string-1: Cisco IOS XR Software, Version 5.3.4[Default]\n\n"
"String-2: Cisco IOS Software, C3900 Software (C3900-UNIVERSALK9-M), Version 15.4(3)M3, RELEASE SOFTWARE (fc2)\n\n"
"String-3: Cisco Nexus Operating System (NX-OS) Software\n\n"
"String-4: Cisco IOS XE Software, Version 16.05.01b Cisco IOS Software [Everest], ISR Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 16.5.1b, RELEASE SOFTWARE (fc1)\n\n"
"IOS XR IOS Nexus Operating System IOS XE\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")