re = /\bCisco\s+(.*?)\s+Software\b/m
str = 'string-1: Cisco IOS XR Software, Version 5.3.4[Default]
String-2: Cisco IOS Software, C3900 Software (C3900-UNIVERSALK9-M), Version 15.4(3)M3, RELEASE SOFTWARE (fc2)
String-3: Cisco Nexus Operating System (NX-OS) Software
String-4: Cisco IOS XE Software, Version 16.05.01b Cisco IOS Software [Everest], ISR Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 16.5.1b, RELEASE SOFTWARE (fc1)
IOS XR IOS Nexus Operating System IOS XE
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end