use strict;
my $str = '@@@hello@! @@@hello@@@';
my $regex = qr/(?s)@@@(.*?)@!/mp;
my $subst = '***$1*^';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";