re = /(?s)@@@(.*?)@!/m
str = '@@@hello@! @@@hello@@@'
subst = '***$1*^'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result