$re = '/(?<=Departure\s+Date.*\,\s+).+(?=\s+\()/m';
$str = 'Departure Date Saturday, 22 May 2021 (until 10:00)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);