re = /(?<=Departure\s+Date.*\,\s+).+(?=\s+\()/m
str = 'Departure Date Saturday, 22 May 2021 (until 10:00)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end