$re = '/(?<=Arrival\s+Date.*\,\s+).+(?=\s+\()/m';
$str = '
Arrival Date Friday, 21 May 2021 (from 12:00)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);