re = /(?<=Arrival\s+Date.*\,\s+).+(?=\s+\()/m
str = '
Arrival Date Friday, 21 May 2021 (from 12:00)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end