re = /Pixel [36]$/m
str = 'Pixel 7 Pro
Pixel 7
Pixel 3
Pixel 3 XL
Pixel 6
Pixel 4
Pixel 5
Pixel 3a
Pixel 6 Pro
Pixel 6 Pro
Pixel 3
Pixel 3 XL
Pixel 3a
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end