#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\?{3}\s*(.+)\s*((?:(?!-{3} admonition)[\s\S])*?)\s*-{3} admonition"
Local $sString = "??? ad-question Quels sont les deux types de bornages ?" & @CRLF & _
"" & @CRLF & _
"Il y en a deux :" & @CRLF & _
"" & @CRLF & _
"- Le bornage amiable." & @CRLF & _
"" & @CRLF & _
"- Le bornage judiciaire." & @CRLF & _
"" & @CRLF & _
"test" & @CRLF & _
"" & @CRLF & _
"--- admonition" & @CRLF & _
"" & @CRLF & _
"??? ad-question Quels sont les deux types de bornages ?" & @CRLF & _
"" & @CRLF & _
"Il y en a deux :" & @CRLF & _
"" & @CRLF & _
"- Le bornage amiable." & @CRLF & _
"" & @CRLF & _
"- Le bornage judiciaire." & @CRLF & _
"" & @CRLF & _
"test" & @CRLF & _
"" & @CRLF & _
"--- admonition"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")