using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\?{3}\s*(.+)\s*((?:(?!-{3} admonition)[\s\S])*?)\s*-{3} admonition";
string input = @"??? ad-question Quels sont les deux types de bornages ?
Il y en a deux :
- Le bornage amiable.
- Le bornage judiciaire.
test
--- admonition
??? ad-question Quels sont les deux types de bornages ?
Il y en a deux :
- Le bornage amiable.
- Le bornage judiciaire.
test
--- admonition";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}