const regex = /((fix|feat|build|chore|ci|docs|style|refactor|perf|test)+(!|s)*(\((\s|\w)*(\))*)*:)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((fix|feat|build|chore|ci|docs|style|refactor|perf|test)+(!|s)*(\\((\\s|\\w)*(\\))*)*:)', 'gm')
const str = `feat: allow provided config object to extend other configs
refactor!: drop support for Node 6
feat(lang): add polish language`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}