re = /((fix|feat|build|chore|ci|docs|style|refactor|perf|test)+(!|s)*(\((\s|\w)*(\))*)*:)/m
str = 'feat: allow provided config object to extend other configs
refactor!: drop support for Node 6
feat(lang): add polish language'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end