$re = '/^(3|4)[0-9]{8}$/m';
$str = '376876768
046786988989877789787h';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);