#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([:,.-])\1+"
Local $sString = "ab::::c ---------d,,,e ..........f ::a-b,,,c..d"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)