$re = '/([:,.-])\1+/';
$str = 'ab::::c ---------d,,,e ..........f ::a-b,,,c..d';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;