using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^=]+\s=\s(?<value_v2c>[^=]+)(?:-|$)";
string input = @".1.3.6.1.2.1.1.3.0 = Timeticks: (2624594000) 303 days, 18:32:20.00 - .1.3.6.1.6.3.1.1.4.1.0 = OID: .1.3.6.1.4.1.14179.2.6.3.39 - .1.3.6.1.4.1.14179.2.2.1.1.1.84.74.0.200.115.112 = Hex-STRING: 54 4A 00 C8 73 70 - .1.3.6.1.4.1.14179.2.2.2.1.1.84.74.0.200.115.112.0 = INTEGER: 0 - .1.3.6.1.4.1.14179.2.2.1.1.3.0 = STRING: ""NJTHAP027""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}