package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^=]+\s=\s(?<value_v2c>[^=]+)(?:-|$)`)
var str = `.1.3.6.1.2.1.1.3.0 = Timeticks: (2624594000) 303 days, 18:32:20.00 - .1.3.6.1.6.3.1.1.4.1.0 = OID: .1.3.6.1.4.1.14179.2.6.3.39 - .1.3.6.1.4.1.14179.2.2.1.1.1.84.74.0.200.115.112 = Hex-STRING: 54 4A 00 C8 73 70 - .1.3.6.1.4.1.14179.2.2.2.1.1.84.74.0.200.115.112.0 = INTEGER: 0 - .1.3.6.1.4.1.14179.2.2.1.1.3.0 = STRING: "NJTHAP027"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}