package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(SI)|["](;)[A-Z]|[0-9](;)["]|[)](;)["]`)
var str = `=SI(renamed="SI";SI(f1<f4;"SI(";"nok");"1;2")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}