re = /(SI)|["](;)[A-Z]|[0-9](;)["]|[)](;)["]/m
str = '=SI(renamed="SI";SI(f1<f4;"SI(";"nok");"1;2")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end