#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?!.*internal).*auditor['’s]*.*(?=report)|(?!.*internal)(?<=report).*auditor['’s]*.*"
Local $sString = "report of auditor" & @CRLF & _
"report of external auditor" & @CRLF & _
"auditor external report" & @CRLF & _
"in auditor report" & @CRLF & _
"auditor report" & @CRLF & _
"internal report of auditor" & @CRLF & _
"report of internal auditor" & @CRLF & _
"auditor internal report"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")