$re = '/(?!.*internal).*auditor[\'’s]*.*(?=report)|(?!.*internal)(?<=report).*auditor[\'’s]*.*/mi';
$str = 'report of auditor
report of external auditor
auditor external report
in auditor report
auditor report
internal report of auditor
report of internal auditor
auditor internal report';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);