#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=\s)\d(?:[-]?\d){5}(?=\s)"
Local $sString = "то есть, матчится:" & @CRLF & _
"111-111" & @CRLF & _
"11-1111" & @CRLF & _
"1-111-11" & @CRLF & _
"" & @CRLF & _
"не матчится:" & @CRLF & _
"111111" & @CRLF & _
"-111111" & @CRLF & _
"111111-" & @CRLF & _
"111--111" & @CRLF & _
"11-11" & @CRLF & _
"1111-1111" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")