import re
regex = re.compile(r"(?<=\s)\d(?:[-]?\d){5}(?=\s)")
test_str = ("то есть, матчится:\n"
"111-111\n"
"11-1111\n"
"1-111-11\n\n"
"не матчится:\n"
"111111\n"
"-111111\n"
"111111-\n"
"111--111\n"
"11-11\n"
"1111-1111\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")