#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-zA-ZáéíóúàèìòùÁÉÍÓÚÀÈÌÒÙ]+ )*+[a-zA-ZáéíóúàèìòùÁÉÍÓÚÀÈÌÒÙ]+$"
Local $sString = "Aarón Ander" & @CRLF & _
"Abel Andrés Joel" & @CRLF & _
"Abelardo Ángel Jon" & @CRLF & _
"Abraham Aníbal Jordi" & @CRLF & _
"Adalberto Antonio Jorge" & @CRLF & _
"Adam Arnau José" & @CRLF & _
"Adán Arturo Jose Antonio" & @CRLF & _
"Adiran Asier Jose Luis" & @CRLF & _
"Adolfo Augusto Jose Manuel" & @CRLF & _
"Adrià Aurelio Jose Maria" & @CRLF & _
"Adrián Baltasar Juan" & @CRLF & _
"Agustín Bartolomé Blas" & @CRLF & _
"Aimar Basilio Juan Antonio" & @CRLF & _
"Aitor Benito Boris" & @CRLF & _
"Alano Benjamín Juan Carlos" & @CRLF & _
"Alberto Bernardo Borja" & @CRLF & _
"Aldo Bienvenido Brahim" & @CRLF & _
"Aleix Blas Brais" & @CRLF & _
"Alejandro Boris Bruno" & @CRLF & _
"Alejo Borja Calisto" & @CRLF & _
"Alex Brahim Juan José" & @CRLF & _
"Alfonso Brais Camilo" & @CRLF & _
"Alfredo Bruno Juan Manuel" & @CRLF & _
"Alonso Calisto Carlos" & @CRLF & _
"Álvaro Camilo Julio" & @CRLF & _
"Amadeo Carlos Cayetano" & @CRLF & _
"Amado Cayetano César" & @CRLF & _
"Amando César Christian" & @CRLF & _
"Ambrosio Christian Claudio" & @CRLF & _
"Amin Claudio Clemente" & @CRLF & _
"Anastasio Clemente Conrado" & @CRLF & _
"Ander Conrado Constantino" & @CRLF & _
"Constantino Francisco Javier Joel" & @CRLF & _
"Crispín Francisco José Jon" & @CRLF & _
"Cristian Gabriel Jordi" & @CRLF & _
"Daniel Gaspar Jorge" & @CRLF & _
"Darío Gerard José" & @CRLF & _
"David Gerardo Jose Antonio" & @CRLF & _
"Desiderio Germán Jose Luis" & @CRLF & _
"Diego Gonzalo Jose Manuel" & @CRLF & _
"Dionisio Gregorio Jose Maria" & @CRLF & _
"Domingo Guillem Juan" & @CRLF & _
"Donato Guillermo Juan Antonio" & @CRLF & _
"Edgar Gustavo Juan Carlos" & @CRLF & _
"Edmundo Hamza Juan José" & @CRLF & _
"Eduardo Héctor Juan Manuel" & @CRLF & _
"Elías Honorato Julio" & @CRLF & _
"Eloy Hugo Justino" & @CRLF & _
"Emilio Humberto Justo" & @CRLF & _
"Eneko Ibai Kevin" & @CRLF & _
"Enrique Ibrahim Kilian" & @CRLF & _
"Eric Ignacio Leo" & @CRLF & _
"Ernesto Iker Leopoldo" & @CRLF & _
"Esteban Isidoro Lorenzo" & @CRLF & _
"Eugenio Ismael Louis" & @CRLF & _
"Eusebio Ivo Lucas" & @CRLF & _
"Fabián Izan Luciano" & @CRLF & _
"Federico Jaime Luis" & @CRLF & _
"Felipe Jan Macario" & @CRLF & _
"Félix Jaume Manuel" & @CRLF & _
"Fermín Javier Marc" & @CRLF & _
"Fernando Jesús Marcelo" & @CRLF & _
"Fidel Joan Marco" & @CRLF & _
"Francisco Joaquín Marcos" & @CRLF & _
"Marcos Pau Tomás" & @CRLF & _
"Mariano Pedro Ulises" & @CRLF & _
"Mario Pelayo Unai" & @CRLF & _
"Marti Plácido Urbano" & @CRLF & _
"Martín Platón Valentín" & @CRLF & _
"Mateo Pol Vicente" & @CRLF & _
"Matías Ponce Víctor" & @CRLF & _
"Mauricio Quintín Virgilio" & @CRLF & _
"Maximiliano Rafael Walter" & @CRLF & _
"Máximo Ramiro Wen" & @CRLF & _
"Miguel Ramón Xabier" & @CRLF & _
"Miguel Ángel Raúl Xavier" & @CRLF & _
"Mikel Ricardo Ximen" & @CRLF & _
"Mohamed Roberto Yerai" & @CRLF & _
"Moisés Rodrigo Yeray" & @CRLF & _
"Nabil Rogelio Yunes" & @CRLF & _
"Narciso Román Yusef" & @CRLF & _
"Nathan Rubén Zacarías" & @CRLF & _
"Nicolás Salvador Zenon" & @CRLF & _
"Noé Samuel Zoilo" & @CRLF & _
"Octavio Santiago" & @CRLF & _
"Oier Sebastián" & @CRLF & _
"Omar Sergi" & @CRLF & _
"Oriol Sergio" & @CRLF & _
"Óscar Silvestre" & @CRLF & _
"Pablo Simón" & @CRLF & _
"Pancho Teodoro"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")