import re
regex = re.compile(r"^([a-zA-ZáéíóúàèìòùÁÉÍÓÚÀÈÌÒÙ]+ )*+[a-zA-ZáéíóúàèìòùÁÉÍÓÚÀÈÌÒÙ]+$", flags=re.MULTILINE)
test_str = ("Aarón Ander\n"
"Abel Andrés Joel\n"
"Abelardo Ángel Jon\n"
"Abraham Aníbal Jordi\n"
"Adalberto Antonio Jorge\n"
"Adam Arnau José\n"
"Adán Arturo Jose Antonio\n"
"Adiran Asier Jose Luis\n"
"Adolfo Augusto Jose Manuel\n"
"Adrià Aurelio Jose Maria\n"
"Adrián Baltasar Juan\n"
"Agustín Bartolomé Blas\n"
"Aimar Basilio Juan Antonio\n"
"Aitor Benito Boris\n"
"Alano Benjamín Juan Carlos\n"
"Alberto Bernardo Borja\n"
"Aldo Bienvenido Brahim\n"
"Aleix Blas Brais\n"
"Alejandro Boris Bruno\n"
"Alejo Borja Calisto\n"
"Alex Brahim Juan José\n"
"Alfonso Brais Camilo\n"
"Alfredo Bruno Juan Manuel\n"
"Alonso Calisto Carlos\n"
"Álvaro Camilo Julio\n"
"Amadeo Carlos Cayetano\n"
"Amado Cayetano César\n"
"Amando César Christian\n"
"Ambrosio Christian Claudio\n"
"Amin Claudio Clemente\n"
"Anastasio Clemente Conrado\n"
"Ander Conrado Constantino\n"
"Constantino Francisco Javier Joel\n"
"Crispín Francisco José Jon\n"
"Cristian Gabriel Jordi\n"
"Daniel Gaspar Jorge\n"
"Darío Gerard José\n"
"David Gerardo Jose Antonio\n"
"Desiderio Germán Jose Luis\n"
"Diego Gonzalo Jose Manuel\n"
"Dionisio Gregorio Jose Maria\n"
"Domingo Guillem Juan\n"
"Donato Guillermo Juan Antonio\n"
"Edgar Gustavo Juan Carlos\n"
"Edmundo Hamza Juan José\n"
"Eduardo Héctor Juan Manuel\n"
"Elías Honorato Julio\n"
"Eloy Hugo Justino\n"
"Emilio Humberto Justo\n"
"Eneko Ibai Kevin\n"
"Enrique Ibrahim Kilian\n"
"Eric Ignacio Leo\n"
"Ernesto Iker Leopoldo\n"
"Esteban Isidoro Lorenzo\n"
"Eugenio Ismael Louis\n"
"Eusebio Ivo Lucas\n"
"Fabián Izan Luciano\n"
"Federico Jaime Luis\n"
"Felipe Jan Macario\n"
"Félix Jaume Manuel\n"
"Fermín Javier Marc\n"
"Fernando Jesús Marcelo\n"
"Fidel Joan Marco\n"
"Francisco Joaquín Marcos\n"
"Marcos Pau Tomás\n"
"Mariano Pedro Ulises\n"
"Mario Pelayo Unai\n"
"Marti Plácido Urbano\n"
"Martín Platón Valentín\n"
"Mateo Pol Vicente\n"
"Matías Ponce Víctor\n"
"Mauricio Quintín Virgilio\n"
"Maximiliano Rafael Walter\n"
"Máximo Ramiro Wen\n"
"Miguel Ramón Xabier\n"
"Miguel Ángel Raúl Xavier\n"
"Mikel Ricardo Ximen\n"
"Mohamed Roberto Yerai\n"
"Moisés Rodrigo Yeray\n"
"Nabil Rogelio Yunes\n"
"Narciso Román Yusef\n"
"Nathan Rubén Zacarías\n"
"Nicolás Salvador Zenon\n"
"Noé Samuel Zoilo\n"
"Octavio Santiago\n"
"Oier Sebastián\n"
"Omar Sergi\n"
"Oriol Sergio\n"
"Óscar Silvestre\n"
"Pablo Simón\n"
"Pancho Teodoro")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")