import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "From:[^@\\r\\n]+@(\\w{2,}\\.)*+(?!(com|net|gov|edu|org)[^\\w\\.]?)";
final String string = "From: user.name@mail.com\n"
+ "From: username@sub.mail.com\n"
+ "From: username@sub.com\n"
+ "From: username@sub.io\n"
+ "From: username@sub.blurdy\n"
+ "From: username@sub.example";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}