re = /From:[^@\r\n]+@(\w{2,}\.)*+(?!(com|net|gov|edu|org)[^\w\.]?)/m
str = 'From: user.name@mail.com
From: username@sub.mail.com
From: username@sub.com
From: username@sub.io
From: username@sub.blurdy
From: username@sub.example'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end