import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d{10})?(?:\\+)?(?:(?:\\d{11})?(?:\\d\\(\\d{3}\\))?(?:(?:\\d{7})?(?:-\\d{3}-\\d{4})?))$";
final String string = "+19999999999\n"
+ "+1(999)9999999\n"
+ "+1(999)-999-9999\n"
+ "9999999999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}