import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!Top\\s+)\\b(\\d+(?:,\\d+)?)\\s+in\\s+([^()\\n]*[^\\s()])";
final String string = "286,879 in Home & Kitchen (See Top 100 in Home & Kitchen)\n"
+ "339 in Cardboard Cutouts\n"
+ "2,945 in Jigsaws (Toys & Games)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}