import re
regex = re.compile(r"(?<!Top\s+)\b(\d+(?:,\d+)?)\s+in\s+([^()\n]*[^\s()])", flags=re.MULTILINE)
test_str = ("286,879 in Home & Kitchen (See Top 100 in Home & Kitchen)\n"
"339 in Cardboard Cutouts\n"
"2,945 in Jigsaws (Toys & Games)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")